Welcome, Guest
Username: Password: Remember me
Forum on Harmonie-36h1

TOPIC: Soil moisture initialization in harmonie / surfex

Soil moisture initialization in harmonie / surfex 7 years 2 months ago #916

Hi all,

i'm looking into the initialization of soil moisture starting from our regional climate model (RACMO), or more generally from HTESSEL or TESSEL, as used by ECMWF, and i am running into several problems

I found that initialization is done via the soil wetness index (SWI), but only for HTESSEL. Because ERA-Interim, ERA-40, and operational ECMWF before July 2007 ( and some of our RACMO runs) use the old TESSEL scheme, I added the option to handle the old tessel.

However, when i run harmonie for a longer period (1 month) it is much too wet. (more than 1mm/day precipitation too wet). This seems to come from the very high evaporation at the surface, which is linked to too much soil water. This also impacts on the radiation balance. In my run, i calculated the monthly averaged fluxes over the Netherlands for August 2006; and found a roughly 30 W/m2 bias in latent heat flux, short wave radiation at the surface, and sw radiation at the top of atmosphere.


It seems that that Prep_ini_surfex uses gl_grib_api to initialize the soil moisture in units of kg/m2, but judging from the surfex output, it should be m3/m3. This is roughly a factor 1000 too high. This gets repaired somewhat later on when Prep_ini_surfex calls fulpos, (where the soilmoisture is probably lowered to field capacity?), but this results in a saturated surface. It then takes the model around 10 days to get rid of the water.


A second issue is with the actual clay fraction map used to calculate the SWI (or the field capacity and wilting point). I think that the low resolution maps from the monthly m?? files are used, and not the high resolution eco-climap ones from PGD.lfi Consequently, the clay fraction is much too low over the netherlands, again leading to problems when initializing the soil moisture.


can anyone with some surfex experience comment on how the initialization should go?

Re:Soil moisture initialization in harmonie / surfex 7 years 1 month ago #936

Ok, i found a bug in my *local* changes in intp_ecmwf_surface.f90, causing the deep soil moisture to be scaled twice, and then end up saturated. The default harmonie should read htessel correctly (ecmwf-operational after july 2007), and i still have to test the old tessel sheme (ecmwf-operational before july 2007)

The too-moist surface in my runs was first caused by not being able to handle the old tessel scheme, and later by my own local bug... However, the initialization of the soil moisture is quite complicated. Because i could not find any documentation, i'll try to document it here:

In gl_grib_api:
1) ecmwf moisture in m3/m3 gets converted to a SWI using the htessel soiltype
2) the SWI is converted to aladin 2-L isba, using the low-resolution clay maps from the monthly climate files m??. Here the units are a percentage (0-100) for clay, kg/m2 for the soil moisture; layer1 has a depth of rd1=10cm, layer2 thickness is taken from the soil depth.

In fullpos
3) fullpos converts the aladin soil moisture back to a SWI, using the same low-res clay map, rd1, and soil depth.Some other checks are done
4) the SWI fields are converted to m3/m3 for use in surfex (3-L isba?); using the hi-res clay map, which contains clay fractions between 0 and 1.


i'll try to redo my runs with (properly) initialized soil moisture.
Time to create page: 0.068 seconds