Welcome, Guest
Username: Password: Remember me
Forum header

TOPIC: obdynac array size not correct

obdynac array size not correct 8 years 3 months ago #665

Running an experiment with Hirlam 7.4 at ECMWF I get an abort in 3DVarAn because the observation array size, which is calculated dynamically in the routine OBDYNAC is too small:

OBDYNAC:plen nobsh_hi nobsh_local 2032924 36194 8276
nrun= 0

ERROR IN SUBROUTINE CMALOAD_DIS
error iprocessor: 20
NOT ENOUGH SPACE TO STORE CMA REPORT
LEN. OF SPACE PROVIDED: 2032924
LEN. OF SPACE ASKED : 2033029
Hint: plen in problemsize namelist!
ABORTING endrun.F

PLEN was removed from the namelist in 2009, OBDYNAC is no longer a switch in Env_expdesc. What to do?

Re:obdynac array size not correct 8 years 3 months ago #666

I have added the switch OBDYNAC=no to the Env_expdesc and this works, at least in this case. Still it seems to me that there is some logic to correct in OBDYNAC.

Re:obdynac array size not correct 8 years 3 months ago #667

Hi,

I've has such crashes in 3DVAR.
Unfortunately it seems that my log file from that case is lost somewhere (at least for now), but the case sounds pretty much the same.

My situation was that when trying to run a relatively large 0.033 d. setup
3DVAR crashed similarly due to some system limits related with MPI that were set to be too low in the submission file. I just had to increase them.

But that was my local platform.

Note:
I'm not sure if this is what's happening with your experiment at ECMWF.
Last Edit: 8 years 3 months ago by Martynas Kazlauskas.

Re:obdynac array size not correct 8 years 3 months ago #668

I think that is a different problem. Mine is definitely linked to the size of the observation array, unconnected to MPI. It occurs for one single analysis in a series.

Maybe there is an additional type of observation that is not accounted for in OBDYNAC? Anybody any ideas?

Re:obdynac array size not correct 8 years 3 months ago #669

Hi,

Well, it seems that my initial deduction was faulty. Can you post your domain params (i guess that) ~wd at ecmwf is ok and the dates that killed your run here?
Last Edit: 8 years 3 months ago by Martynas Kazlauskas.

Re:obdynac array size not correct 8 years 3 months ago #670

  • Xiaohua Yang
  • Xiaohua Yang's Avatar
  • OFFLINE
  • Administrator
  • Posts: 195
  • Thank you received: 4
Ben Wichers Schreur wrote:
I think that is a different problem. Mine is definitely linked to the size of the observation array, unconnected to MPI. It occurs for one single analysis in a series.

Maybe there is an additional type of observation that is not accounted for in OBDYNAC? Anybody any ideas?

Ben,
I saw this post while in SMHI attending HARMONIE training course and Magnus Lindskog believed that he has a solution. I understood that he was to put this on his todo list in the coming weeks but he thought this is not most urgent now because you have already got an alternative solution for the time being.
I regret if this had not been communicated in private earlier.
Time to create page: 0.078 seconds