Welcome, Guest
Username: Password: Remember me
Forum header
  • Page:
  • 1
  • 2

TOPIC: solved: 7.4 issues

solved: 7.4 issues 8 years 2 months ago #424

Hi
I try to install 7.4beta1 and have some problems with climate generation. Looking at log file, I can see "hdf2asim.x" failing to read some input file, probably looking for something that does not exist.
I attach the log file and files from ClimateFailed and Climate_monthFailed folders.

Any comments?

File Attachment:

File Name: climfailed.tgz
File Size: 23991

File Attachment:

File Name: climfailed.tgz
File Size: 23991
Last Edit: 8 years 2 months ago by Andres Luhamaa. Reason: problem solved

Re:7.4 issues 8 years 2 months ago #425

Andres,

I had problems installing 7.4 with climate failing do to issues with hdf/netcdf libraries (though those were present in the system), but solved those.
Don't know if that's the case. Could you attach the "real" log file here? I found only zipped climate build related folders attached.
Last Edit: 8 years 2 months ago by Martynas Kazlauskas.

Re:7.4 issues 8 years 2 months ago #426

Thanks,
looks like I really attached the same file twice. I have had problems with HDF libraries since 7.1 at least and have compiled HDF separately and this has worked. So I do not think this is HDF library problem.

Climate log here

File Attachment:

File Name: Climate.gz
File Size: 6715

Re:7.4 issues 8 years 2 months ago #427

Hi Andres,

Might it be so that you tried to launch climate generation on 4 cores (LAUNCH as "mpirun - np 4" ) , therefore you have the failure of 4 simultanoues jobs reading the same namelist file (therefore the end of file during read failure) etc.
?
Shouldn't climate generation go on a single core instead?
Last Edit: 8 years 2 months ago by Martynas Kazlauskas.

Re:7.4 issues 8 years 2 months ago #428

Hi Andres,

It looks like your general setup uses mpi calls for launching within the Boot script.
For hdf2asim, however, I guess that it is a good idea to disable the mpi call. You can try to do this by modifying the hdf2asim call in the 'Climate' script, and set $LAUNCH to an empty string:

Boot LAUNCH="" PGM=hdf2asim < namlis || exit

Kai

Re:7.4 issues 8 years 2 months ago #430

Hi,
I removed LAUNCH from config file, so there are no more mpi calls. But it does not seem to change the problem much.

File Attachment:

File Name: Climate-e8d669883898005d81ad997573e574fa.gz
File Size: 12669
Last Edit: 8 years 2 months ago by Andres Luhamaa. Reason: attach file

Re:7.4 issues 8 years 2 months ago #431

  • Laura Rontu
  • Laura Rontu's Avatar
  • OFFLINE
  • Administrator
  • Finnish Meteorological Institute
  • Posts: 150
  • Thank you received: 8
I wonder if you could forget these troubles and create the climate files in ECMWF computers instead? That is the way things have been done for years ... I guess your problems are not connected with MSO-SSO, radoro or FLake fields, which are treated when creating the monthly files and lake cold start fields also when combining the monthly files to daily climate. To get these all consistent, you need to have from the very beginning all three things switched on in Env_expdesc. For lakes, you need a couple of extra files for lake depth and cold start climate. They are stored in ecfs.

Re:7.4 issues 8 years 2 months ago #432

Hi Andres,

Could you also post or e-mail your configuration file that you used from src/config ?
Last Edit: 8 years 2 months ago by Martynas Kazlauskas.

Re:7.4 issues 8 years 2 months ago #433

Laura,
I switched off everything I could imagine about SSO-MSO and FLAKE in Env_expdesc. I guess it really could save some time to prepare climate in ecmwf, but on the other hand, as we are not full members of ECMWF, it is not a real solution for operational environment. But working solution is of course better than no solution at all. Could You remind me, what is the command for creating climate files only, something like: Hirlam PLAYFILE=climate ???

Martynas, I attach exp dir.

File Attachment:

File Name: test.tgz
File Size: 54091

Re:7.4 issues 8 years 2 months ago #434

  • Laura Rontu
  • Laura Rontu's Avatar
  • OFFLINE
  • Administrator
  • Finnish Meteorological Institute
  • Posts: 150
  • Thank you received: 8
The serial production of climate files in ECMWF might not work correctly. Kalle used it and got problems, namely zero depth of all lakes. It is easier to start 6 times experiment like Hirlam Start DTG=2010010100 LL=0 and so every second month because you create two files at the time. You will get also the lake cold start daily climates for every DTG you define, please store them also (cl00010100 etc) for future use. And please switch on all you can find on MSO, radoro and Flake, just to have the fields in the future when you want to try these parametrizations. They do no harm in climate files even if you do not use the parametrizations.

Re:7.4 issues 8 years 2 months ago #435

Editing this post now.
Last Edit: 8 years 2 months ago by Martynas Kazlauskas.

Re:7.4 issues 8 years 2 months ago #436

Hi Andres,

A shot in the dark as I i'm short of time for a longer explanations now.

add -DWORDRECLEN to MACHINECPP variables. I reproduced similar problem as yours though on Intel configuration, and that seems to be the cause.

It's in some way related with Asimof conversion if i'm not mistaking, but maybe someone else could comment more on that.


Sorry, this does not seem to be right.
Last Edit: 8 years 2 months ago by Martynas Kazlauskas.

Re:7.4 issues 8 years 2 months ago #437

Hi Andres,

The first error that I can spot in the log file is
forrtl: severe (24): end-of-file during read, unit 5, file stdin, line 29, position 0

So hdf2asim stopped, because it expected more input lines from the namelist then there actually are. The namelist file that is used in the call to hdf2asim is namlis, and this file can be found in directory Climate_monthFailed. Now namlis only has 28 lines.

So one possibility that could cause the error is the namelist termination character, which in your namlis file is a /. Maybe your FORTRAN environment expects another termination character (some systems expect an & e.g.).

Unless you already have given up on this, you could try to find out about this as follows:
  1. cd into Climate_monthFailed
  2. run hdf2asim from the command line like ../lib/src/<config name of your system>/bin/hdf2asim.x < namlis
  3. In your first trial this should reproduce the error
  4. Change the termination character or other parts in namlis and retry the hdf2asim command

Maybe this can help to identify the problem.

Re:7.4 issues 8 years 2 months ago #438

Thanks Kai,
at the moment namlis did not contain any namelist end symbol at all. Added it manually and it worked. It could very easily be my problem, because I have modified the Climate_month script a bit already and maybe added some extra character somewhere. I'll make clean experiment now and see whether namelist comes correctly or not.

Re:7.4 issues 8 years 2 months ago #439

Case closed, the problem was likely afterall the mpi call to hdf2asim.x
  • Page:
  • 1
  • 2
Time to create page: 0.109 seconds